[hobbit] conn test stuck on red

Buchan Milne bgmilne at staff.telkomsa.net
Tue Aug 4 10:23:42 CEST 2009

On Monday, 3 August 2009 14:01:36 Leon Volfson wrote:
> Hi,
> I'm using version 4.3.0-beta2 on Ubuntu 8.04.1 server.
> I've experienced some ISP networking problems this morning, which made
> Xymon mark all the connections red.
> After a few minutes the network went back to normal, but the red
> "lights" stayed on.
> It was only the conn test, all the other including telnets to port 80
> were green.
> I tried restarts and such - nothing helped. The only thing that did help
> was "apt-get dpkg-reconfigure".
> The one thing that I did notice is that it always tried to ping an
> OpenDNS server, as this is the one I have in resolv.conf.

Don't use OpenDNS for name resolution on a monitoring system, as the false 
positive results will hurt you ...

Or, if you must, use the 'testip' option for every host in bb-hosts.

> What I wanted to ask is if there are any ways to remove some cache or
> temp files instead of doing dpkg-reconfigure as it's a bit of an ugly
> solution,

Well, the things that could have made a difference here are:
-restarting hobbit
-invalidating any (non-hobbit) name resolution caches (e.g. nscd etc.).

> although absolutely clean and fast - took me 5 seconds without loosing
> any data.


More information about the Xymon mailing list