<div dir="ltr">The xymonserver.cfg file isn't a script, it just *looks* like one.  It's normally interpreted by xymon binaries that *do* understand the "directory" command, which allows you to break up a config file into manageable chunks.<div><br></div><div>  E.g.  xymonlaunch  in the xymon startup script  (it's all one line in the file, I just added newlines and indents for clarity):<div><br></div><div><div>/home/xymon/server/bin/xymonlaunch </div><div>     --config=/home/xymon/server/etc/tasks.cfg </div><div>     --env=/home/xymon/server/etc/xymonserver.cfg </div><div>     --log=/var/log/xymon/xymonlaunch.log </div><div>     --pidfile=/var/log/xymon/xymonlaunch.pid</div></div><div><br></div><div>Note the "--env=/home/xymon/server/etc/xymonserver.cfg", which tells the xymonlaunch program where to load up environmental information when it first starts up.</div><div><br></div><div>Ralph Mitchell</div><div><br></div><div><br></div></div></div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Jul 25, 2018 at 8:03 AM, Ian Diddams via Xymon <span dir="ltr"><<a href="mailto:xymon@xymon.com" target="_blank">xymon@xymon.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">______________________________<wbr>_________________<br>
Xymon mailing list<br>
<a href="mailto:Xymon@xymon.com">Xymon@xymon.com</a><br>
<a href="http://lists.xymon.com/mailman/listinfo/xymon" rel="noreferrer" target="_blank">http://lists.xymon.com/<wbr>mailman/listinfo/xymon</a><br>
<br><br>---------- Forwarded message ----------<br>From: Ian Diddams <<a href="mailto:didds3@yahoo.co.uk">didds3@yahoo.co.uk</a>><br>To: Xymon Mailing List <<a href="mailto:xymon@xymon.com">xymon@xymon.com</a>><br>Cc: <br>Bcc: <br>Date: Wed, 25 Jul 2018 12:03:32 +0000 (UTC)<br>Subject: directory command?<br><div><div style="font-family:Helvetica Neue,Helvetica,Arial,sans-serif;font-size:10px"><div><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><a href="http://xymon.sourceforge.net/" rel="nofollow" target="_blank">Xymon 4.3.28-1.el7.terabithia</a> server<br>centos 77.4.1708<br><br>installed via rpm</b></font></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><br></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><br></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span>the cfg file <span>"/etc/xymon/xymonserver.<wbr>cfg" contains the oline (line 261)</span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span><br></span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span><span><div>directory /etc/xymon/xymonserver.cfg.d</div><div><br></div></span><div><span><font color="silver"><b><span><span><br></span></span></b></font></span></div><div><span><font color="silver"><b><span><span><br></span></span></b></font></span></div>However...<br><br>when that .cfg file is "run" i.e</span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span>     . . <span><b style="color:rgb(192,192,192)">/etc/xymon/xymonserver.cfg</b></span></span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span><br></span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span>it errors with </span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span><br></span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span><br><span><div>directory: not found [No such file or directory]</div><div><br></div></span><br><br>The adftual directory <span><b style="color:rgb(192,192,192)"> /etc/xymon/<wbr>xymonserver.cfg.d exists and has suitable ownerships and permissions...  the error is about the _command_ "directory".<br></b></span><br>I can;t yum install it - Ive never even heard of it TBH. Im assuming its some sort internal thing to xymon?</span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span><br></span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span>cheers</span></span></b></font></span></div><div><span><font color="silver" face="bookman old style, new york, times, serif" size="5"><b><span><span><br></span></span></b></font></span></div><div><font color="silver"><b><font face="bookman old style, new york, times, serif" size="5">ian</font>- <br><br></b></font></div></div></div><br></blockquote></div><br></div>