<div dir="ltr">Martin,<div><br></div><div>Thanks!  Makes sense.  I guess the alerts.cfg.5.html file needs to be changed?  That's where I was looking...</div><div><b style="color:rgb(0,0,0);font-family:'Times New Roman';font-size:medium">COLOR=color[,color]</b><span style="color:rgb(0,0,0);font-family:'Times New Roman';font-size:medium"> Rule matching an alert by color. Can be "red", "yellow", or "purple". The forms "!red", "!yellow" and "!purple" can also be used to NOT send an alert if the color is the specified one.</span><br></div><div class="gmail_extra"><br><div class="gmail_quote">Well, that fixed my first issue.  Now when the cpu is reporting green, the --test gives me a "Failed" message as expected, but with the cpu reporting yellow, I get the same "Failed" message - failed due to color!</div><div class="gmail_quote"><br></div><div class="gmail_quote">Even took xymoncmd out of the equation and the result is the same.</div><div class="gmail_quote">Took out EXSERVICE as well.</div><div class="gmail_quote"><br></div><div class="gmail_quote">Now all I have in alerts.cfg:</div><div class="gmail_quote">PAGE=mypage</div><div class="gmail_quote">  MAIL <a href="mailto:me@here.com">me@here.com</a> COLOR=%(red|yellow)</div><div class="gmail_quote"><br></div><div class="gmail_quote">..yet when I run:</div><div class="gmail_quote"> xymond_alert --test <a href="http://server.com">server.com</a> cpu</div><div class="gmail_quote">I get..</div><div class="gmail_quote">#### DATE TIME Failed 'MAIL <a href="mailto:me@here.com">me@here.com</a> COLOR=%(red|yellow)' (color)</div><div class="gmail_quote"><br></div><div class="gmail_quote">Any other suggestions?  For example, do I have to restart the server after making changes to the alerts.cfg file?</div><div class="gmail_quote"><br></div><div class="gmail_quote">Thanks,</div><div class="gmail_quote">David</div><div class="gmail_quote"><br></div><div class="gmail_quote"><br></div><div class="gmail_quote">On Wed, Nov 11, 2015 at 10:10 PM, Martin Lenko <span dir="ltr"><<a href="mailto:lenko99@gmail.com" target="_blank">lenko99@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Hi David,<div>to specify multiple color values you will have to use regular expression. Use something like this in your alert config:</div><div>COLOR=%(yellow|red)</div><div><br></div><div>The '%' character instructs xymon that following string is a regular expression.</div><div><br></div><div>Regards,</div><div>Martin</div></div><div class="gmail_extra"><br><div class="gmail_quote"><div><div>On 11 November 2015 at 18:46, David Welker <span dir="ltr"><<a href="mailto:dewelker@gmail.com" target="_blank">dewelker@gmail.com</a>></span> wrote:<br></div></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div><div dir="ltr">I admit, this is my first attempt at alerting, so this may or may not be user error.  It also could be an issue that is fixed in the latest upgrade (I'm still on 4.3.21), but before I resort to that (which will be soon enough), I wanted to make sure I was at least thinking along the right line...<div><br></div><div>The cpu column is reporting green.</div><div>The entry in alerts.cfg includes a COLOR=yellow parameter.</div><div>Running the xymond_alert --test reports (as expected)...</div><div>Failed 'MAIN me@here COLOR=yellow EXSERVICE=conn,disk' (color)</div><div><br></div><div>If, however, I change the COLOR to red, or even if I just add it (COLOR=yellow,red), I get the "Mail alert with command 'mail -s...'" line rather than the failed.  Did I do something wrong?</div><div><br></div><div>Funny though, either way I don't actually get the email.</div><div><br></div><div>Thanks,</div><div>David</div></div>
<br></div></div>_______________________________________________<br>
Xymon mailing list<br>
<a href="mailto:Xymon@xymon.com" target="_blank">Xymon@xymon.com</a><br>
<a href="http://lists.xymon.com/mailman/listinfo/xymon" rel="noreferrer" target="_blank">http://lists.xymon.com/mailman/listinfo/xymon</a><br>
<br></blockquote></div><br></div>
</blockquote></div><br></div></div>