<html>
  <head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">On 11/12/2015 9:37 AM, David Welker
      wrote:<br>
    </div>
    <blockquote
cite="mid:CAAOtyH+dw6NJZvpXzaAYRm2HduMZ6ZzSJSumqTWtW8bdDw_Npw@mail.gmail.com"
      type="cite">
      <div dir="ltr">jc,
        <div><br>
        </div>
        <div>Using your idea...</div>
        <div>PAGE=mypage COLOR=red,yellow</div>
        <div>   MAIL <a moz-do-not-send="true"
            href="mailto:me@here.com">me@here.com</a></div>
        <div><br>
        </div>
        <div>...when cpu is green, yellow, purple, or red --test now
          always returns a mail -s with CRITICAL (RED) message.</div>
        <div><br>
        </div>
        <div>which may actually BE correct, since elsewhere on the page
          there is a red status and I've now put the COLOR on the main
          line referencing the whole page. In an attempt to narrow it
          back down to the one host, however, I used HOST=^Server1*,
          instead of PAGE=, but STILL get the CRITICAL (RED) message in
          the --test run, but actually got an email regarding the yellow
          cpu status (and not for a different yellow status on the same
          page).</div>
        <div><br>
        </div>
        <div>--dump-config returns...</div>
        <div>HOST=^Server1* COLOR=yellow,red     <---- NOTICE
          REVERSED COLORS (see above)??</div>
        <div>MAIL <a moz-do-not-send="true" href="mailto:me@here.com">me@here.com</a>
          FORMAT=TEXT REPEAT=30</div>
        <div><br>
        </div>
        <div>Interestingly enough, when I use a --color parameter with
          the --test, it performs correctly...</div>
        <div>If --color of cpu is yellow, --test returns a warning
          (YELLOW) message.<br>
        </div>
        <div>If --color of cpu is red, --test returns a CRITICAL (RED)
          message.</div>
        <div>If --color of cpu is green or purple, --test returns a
          FAILED (due to color) message.</div>
        <div class="gmail_extra"><br>
        </div>
        <div class="gmail_extra">
          <div>By the way, my ALERTCOLORS="red,yellow,purple"</div>
          <div><br>
          </div>
          <div>Could it possibly be that the --test feature needs more
            testing, and that the alerting is actually working the way I
            expect it should?</div>
          <br>
        </div>
      </div>
    </blockquote>
    <br>
    Actually, this could be more of a documentation issue I suppose.<br>
    <br>
    xymond_alert when in --test mode should really always have a
    --color= specified (so that it knows what to test for).<br>
    <br>
    Based on how it responded after you'd added that in, I believe it's
    working as intended there.<br>
    <br>
    Regards,<br>
    -jc<br>
  </body>
</html>