[Xymon] Cannot link with SSL Library

Robles, Chris CROBLE at milwaukee.gov
Fri Sep 18 19:00:18 CEST 2015

Thank you.  This work-around, worked.  I had to delete my Xymon install folder and un-package a fresh copy, but once I did that and followed these instructions, Xymon compiled with OpenSSL support.

From: Scott Pfister [mailto:icepickjazz at gmail.com]
Sent: Tuesday, August 11, 2015 11:59 AM
To: Robles, Chris
Cc: xymon at xymon.com
Subject: Re: [Xymon] Cannot link with SSL Library

Check out this old post.  http://lists.xymon.com/archive/2007-June/013621.html ...

It seems that your openssl libraries do not automatically pull in the

libdl library when you link with it.

As a workaround, you can change build/Makefile.test-ssl: The "test-link"

command reads

   @$(CC) $(CFLAGS) $(OSSLLIB) -o test-ssl test-ssl.o -lssl -lcrypto $(NETLIBS)

Add a "-ldl" after the "$(NETLIBS)".

That should allow the configure script to complete. After that, you must

change the top-level Makefile: It has a line with

   SSLLIBS = -L/usr/lib -lssl -lcrypto

Change that to

   SSLLIBS = -L/usr/lib -lssl -lcrypto -ldl



On Mon, Aug 10, 2015 at 12:10 PM, Robles, Chris <CROBLE at milwaukee.gov<mailto:CROBLE at milwaukee.gov>> wrote:
New installation of Xymon 4.3.21 on OpenSUSE 13.2.  Xymon won’t compile with SSL support even though I have OpenSSL and libopenssl-devel installed.  When I run “openssl version” it says OpenSSL 1.0.1k-fips.
Here is what I see when I run ./configure:  (note: I also tried running configure.server with –sslinclude and –ssllib).   When I run “openssl verions –a” I don’t see gcc listed under compiler.  I see “-I. –I.. –I../incluse –fPIC” etc.  I may have installed gcc after openssl, but gcc is installed.

Checking for OpenSSL ...
Compiling with SSL library works OK
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_globallookup':
dso_dlfcn.c:(.text+0x11): undefined reference to `dlopen'
dso_dlfcn.c:(.text+0x24): undefined reference to `dlsym'
dso_dlfcn.c:(.text+0x2f): undefined reference to `dlclose'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_bind_func':
dso_dlfcn.c:(.text+0x344): undefined reference to `dlsym'
dso_dlfcn.c:(.text+0x3eb): undefined reference to `dlerror'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_bind_var':
dso_dlfcn.c:(.text+0x464): undefined reference to `dlsym'
dso_dlfcn.c:(.text+0x50b): undefined reference to `dlerror'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_load':
dso_dlfcn.c:(.text+0x579): undefined reference to `dlopen'
dso_dlfcn.c:(.text+0x5db): undefined reference to `dlclose'
dso_dlfcn.c:(.text+0x613): undefined reference to `dlerror'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_pathbyaddr':
dso_dlfcn.c:(.text+0x69f): undefined reference to `dladdr'
dso_dlfcn.c:(.text+0x701): undefined reference to `dlerror'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_unload':
dso_dlfcn.c:(.text+0x752): undefined reference to `dlclose'
collect2: error: ld returned 1 exit status
Makefile.test-ssl:7: recipe for target 'test-link' failed
make: *** [test-link] Error 1
Warning: Cannot link with SSL library
OpenSSL include- or library-files not found.
Although you can use Xymon without OpenSSL, you will not
be able to run network tests of SSL-enabled services, e.g. https.
So installing OpenSSL is recommended.
OpenSSL can be found at http://www.openssl.org/

If you have OpenSSL installed, use the "--sslinclude DIR" and "--ssllib DIR"
options to configure to specify where they are.

Chris Robles   |   City of Milwaukee   |  Information Technology & Management Division  | Ph: 414.286.8096<tel:414.286.8096>  |   Chris.Robles at milwaukee.gov<mailto:Chris.Robles at milwaukee.gov>

The City of Milwaukee is subject to Wisconsin Statutes related to public records. Unless otherwise exempted from the public records law, senders and receivers of City of Milwaukee e-mail should presume that e-mail is subject to release upon request, and is subject to state records retention requirements. See City of Milwaukee full e-mail disclaimer at www.milwaukee.gov/email_disclaimer<http://www.milwaukee.gov/email_disclaimer>

Xymon mailing list
Xymon at xymon.com<mailto:Xymon at xymon.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xymon.com/pipermail/xymon/attachments/20150918/3f7ba7a0/attachment.html>

More information about the Xymon mailing list