[Xymon] Xymon Newbie - Installation Issues

Sam Robert sam.robert at outlook.com
Thu Aug 21 21:10:29 CEST 2014

The number of times that I have re-installed this over and over again made me realize that fact :)
Every time that configure would throw up errors it was looking for a header file and figured out all those header files were in the devel packages. But like someone suggested, RHEL by itself does not have all the packages at least in its base install and you need to go look elsewhere (RPMforge) or other places (CentOS Packages) etc to get what you need and that's what was throwing me off constantly.
I just got very detailed instructions for Ubuntu and am in the process of implementing that to see if that works. I'll take any distro as long as I can get Xymon to work. From what I have seen so far, Xymon indeed appears to be the best in its class so will do whatever it takes to get it going.
Thank you for the answers. Appreciate all the help.

From: novosirj at ca.rutgers.edu
To: sam.robert at outlook.com
CC: josh at imaginenetworksllc.com; xymon at xymon.com
Date: Thu, 21 Aug 2014 15:03:32 -0400
Subject: Re: [Xymon] Xymon Newbie - Installation Issues

Are you perhaps not realizing that for some of these you need the -devel packages not just the actual packages. Requiring header files is a common giveaway. 

Sent from my iPhone
On Aug 21, 2014, at 14:09, "Sam Robert" <sam.robert at outlook.com> wrote:

Yes. That's how I was eventually able to install rrdtool. There's just no other way that it would work.

Date: Thu, 21 Aug 2014 13:55:30 -0400
Subject: Re: [Xymon] Xymon Newbie - Installation Issues
From: josh at imaginenetworksllc.com
To: sam.robert at outlook.com
CC: paul.root at centurylink.com; xymon at xymon.com

Have you changed the repos at all?  You might install RPMforge for it and many other great packages.
Josh Luthman

Office: 937-552-2340

Direct: 937-552-2343

1100 Wayne St

Suite 1337

Troy, OH 45373
On Aug 21, 2014 1:41 PM, "Sam Robert" <sam.robert at outlook.com> wrote:

It says "yum no package rrdtool available" on a default instance of RHEL on Amazon AWS. Also, RRDTool is the one I am having the most trouble with on each distro. I have tried it on RHEL, Suse, Ubuntu & Amazon Linux. On each it's either not available or if it's available always has issues installing whether its the dependencies that are suddenly missing or something else. Didn't have any idea it was going to be so difficult to install RRDTool. Oh and where I used the YUM install, Xymon configure started throwing fits about not finding either RRDTool 1.0 or 1.2.

From: Paul.Root at CenturyLink.com
To: sam.robert at outlook.com; xymon at xymon.com
Subject: RE: [Xymon] Xymon Newbie - Installation Issues

Date: Thu, 21 Aug 2014 13:25:04 +0000

What’s wrong with “yum install rrdtool-devel”?




From: Xymon [mailto:xymon-bounces at xymon.com]
On Behalf Of Sam Robert

Sent: Thursday, August 21, 2014 2:29 AM

To: xymon at xymon.com

Subject: [Xymon] Xymon Newbie - Installation Issues


Hello All,


I am a Linux and Xymon newbie to begin with so please go easy on me. Found Xymon in my search for a simple yet powerful network monitor and love what I have seen so far. However I cant seem
 to get it installed properly no matter what. So far I have tried all instances of Linux over at AWS and so far the best with the least amount of errors is Red Hat Enterprise Linux 7.0 - Even on that, the RRDTOOL-DEVEL is nowhere to be found and after spending
 half a day found the rpm at REPOFORGE and installed from there and the ./configure seemed happy with it. However no matter what I do, I could not find C-ARES-DEVEL to install and the RPM I found gave constant errors.


Anyhow, my question is what to do with the C-ARES error or the ARES.H errors on configure. Let them be or how can I install them properly? Also after the installation how do I configure APACHE
 as on other distros I could never get the XYMON page to come up because of a different www folder and each distro has its own issues.


Does anybody know of a complete guide or tutorial for newbies using which I can get Xymon to work? I have followed almost 8 to 10 different Xymon articles for different distros and could
 not get any to work because of the versions difference and other issues.


Please Help!





Xymon mailing list

Xymon at xymon.com


Xymon mailing list
Xymon at xymon.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xymon.com/pipermail/xymon/attachments/20140821/d2a73634/attachment.html>

More information about the Xymon mailing list