[Xymon] xymonnet error - will not start due to pcre

Sheldon Campbell campbell_sjc at hotmail.com
Thu Dec 12 21:05:12 CET 2013

Thanks everyone for your responses.   As per responses I updated my .profile for userid xymon to have the following defined yet I still received the error messages. However I tried adding those same values to the xymon.sh shell script and the xymonnet is no longer writing errors,..it's working but not sure why I had to override it within the xymon.sh shell script.
export LIBPATH=/usr/local/lib:/usr/libexport LD_LIBRARY_PATH=/usr/local/lib:/usr/lib
From: Rolands at logicaltech.com.au
To: xymon at xymon.com
Date: Wed, 11 Dec 2013 22:59:57 +0000
Subject: Re: [Xymon] xymonnet error - will not start due to pcre

Maybe a typo but it should be /usr/local/lib not /usr/local/bin
run ldd /usr/local/xymon/server/bin/xymonnet or wherever your xymon installation is.
It will show you what is missing.
What xymon version and OS do you run?


From: Xymon [mailto:xymon-bounces at xymon.com]
On Behalf Of Sheldon Campbell

Sent: Thursday, 12 December 2013 9:46 AM

To: xymon at xymon.com

Subject: [Xymon] xymonnet error - will not start due to pcre




Hope someone can offer insight into this issue whereby the xymonnet.log continues to report the following error.


exec(): 0509-036 Cannot load program xymonnet because of the following errors:

        0509-150   Dependent module ../lib/libpcre.a(libpcre.so.1) could not be loaded.

        0509-022 Cannot load module ../lib/libpcre.a(libpcre.so.1).

        0509-026 System error: A file or directory in the path name does not exist.


I have tried setting the following to LIBRARY PATH's but this has not helped


export  LD_LIBRARY_PATH="/usr/local/bin"

export LIBPATH="/usr/local/bin"



Xymon mailing list
Xymon at xymon.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xymon.com/pipermail/xymon/attachments/20131212/7159886b/attachment.html>

More information about the Xymon mailing list