[Xymon] Simple Network Tests not displaying

Michael Beatty Michael.Beatty at sherwin.com
Thu Dec 13 18:28:09 CET 2012

Thank you for your reply.

The root issue had everything to do with me not understanding how the 
host.cfg file works.  Namely, when there is more that one host named in 
the file.  In this case, my server is also a client.  I had the server 
defined with its own tags at the top of the hosts file, these tags were 
specific to what I wanted reported on the "server" page and didn't 
include the network tests.  Further down in the hosts.cfg file, I had 
the server again as a client.  I added the tags for those network 
service tests in that location.  Since the host was already defined, 
these tags were ignored.  To correct the issue, I put all of the tags I 
needed with the original host declaration, added a "prefer" tag to it to 
ensure it had priority and put an noconn tag with the second host to 
ensure it didn't have priority.

Michael Beatty

On 12/12/2012 12:07 PM, cleaver at terabithia.org wrote:
>> If I run xymonnet manually I get:
>> 2012-12-12 12:00:18 Could not run the command 'xymonping -Ae' (exec
>> failed)
>> 2012-12-12 12:00:18 Command 'xymonping' failed: No such file or directory
>> If I'm running xymonnet in debug I keep seeing a problem with the ping
>> test....
>> 1187 2012-12-12 11:55:54 Adding to combo msg: status+30 mxbscs.conn
>> clear <!-- [flags:OrdAstLe] --> Wed Dec 12 11:55:54 2012 conn ok :
>> System failure of the ping test
>> If I run it as --no-update I get:
>> status+30 mxbscs.conn clear <!-- [flags:OrdAstLe] --> Wed Dec 12
>> 11:59:21 2012 conn ok : System failure of the ping test
>> Service conn on mxbscs is OK
>> Xymon system error
> Well, that would seem to be part of it at least. Did xymonping go away, or
> did you make any recent changes to the config? Could also be a missing
> -jc
>> Michael Beatty
>> Sherwin-Williams
>> IT Analyst/Developer
>> michael.beatty at sherwin.com
>> 216-515-7374
>> On 12/12/2012 09:44 AM, Michael Beatty wrote:
>>> I'm not getting any data about my clients on any simple network tests,
>>> such as, ssh, telnet, etc.  The only column that is showing up that is
>>> listed in the hosts.cfg man page is "bbd"
>>> I'm using the default protocols.cfg and tasks.cfg.  xymonnet.log file
>>> is small, doesn't have any data in it since June.
>>> The xymonnet column for my server is showing data and statistics.
>>> Any help would be appreciated.
>> _______________________________________________
>> Xymon mailing list
>> Xymon at xymon.com
>> http://lists.xymon.com/mailman/listinfo/xymon

More information about the Xymon mailing list