[Xymon] Apache tag not working, not playing nice with http tag.

Henrik Størner henrik at hswn.dk
Sun Jul 31 11:51:04 CEST 2011

> I've been trying to get apache results and am getting nothing, no
> results, no errors, as if it the tag wasn't there.
> UNLESS, and this is the weird part -  *IF* I disable http for a given
> server I get *stats* under apache on the trends page, but still no
> apache column on the server page.
> Disabling http is not an option, as we've got nonstandard ports getting tested.
> With any http test enabled, just get blank "nan" values for apache.
> And no matter what, we don't get an apache column.

The data for the Apache stats don't generate an Apache status - it just 
generates an apache RRD file, you can see it in the "trends" column.

I've tried reproducing your problem here, but I cannot - no matter how I 
try to configure hosts.cfg, when running the network tests I get both 
the normal "http" status update, and the "apache" data update.

Could you try running the network tests against that host like this:

xymoncmd xymonnet --noping --debug --no-update HOSTNAME 2>&1 >log.txt

and see if there is a line with "data HOSTNAME.apache" together with the 
apache statistics in there ?


More information about the Xymon mailing list