[hobbit] red conn lights in xymon

Buchan Milne bgmilne at staff.telkomsa.net
Wed May 5 16:24:02 CEST 2010

On Wednesday, 5 May 2010 14:27:55 Charles Dillard wrote:
> Hello, I’m installing xymon 4.2.3 on a Dell 1950 with a Redhat RHEL 5 64
>  bit OS. I first install
> rrdtool-1.0.50-3.el5.rf.x86_64.rpm
> rrdtool-devel-1.0.50-3.el5.rf.x86_64.rpm
> pcre-8.01.zip
> then
> xymon-4.2.3.tar.gz

IMHO, using packages makes a lot more sense than compiling from source ...

> After I start httpd and xymon, two aspects of monitoring fail:
> 1. the conn test is always red for the 90 or so servers we monitor and

Can you ping them from the host manually? What are you using for the ping test 
(see the FPING variable in hobbitserver.cfg)?

> 2. the http [wget] test is white on the four web servers we run.

Due to (1), network tests are suspended for hosts with active but failed conn 

> We monitor both Windows 2003 servers and mostly Redhat AS 3  servers. The
>  other monitoring tests like disk and cpu work.

These are done locally and reported to the server, whereas ping tests are run 
from the server by the bbtest task and reported to the server. Some server-
related issues could cause problems here (such as inability to write temporary 

> netstat –van shows port 1984 is up and listening. The output on the xymon
>  startup is what I would call nominal.
> hobbit 4.2.0 has worked for years on a Redhat AS 3 server at our agency.
>  We’re trying to upgrade here to RHEL 5.
> I’ve tried substituting hobbit 4.2.0 for xymon with the same results.
> The use of yum is not an option for installation on our USDOJ network.

I highly doubt that, yum can be used without "network", e.g. by local repos 


More information about the Xymon mailing list