[hobbit] Problem building Hobbit on a Solaris 10 zone - Summary/Resolution

Eric Meddaugh etmsys at rit.edu
Thu Aug 14 17:17:15 CEST 2008

What's your /etc/zones/<zonename>.xml look like?  Is it loopback mounted
r/o, or r/w?


-----Original Message-----
From: John P Martin [mailto:jmartin23 at csc.com] 
Sent: Thursday, August 14, 2008 11:10
To: hobbit at hswn.dk
Subject: RE: [hobbit] Problem building Hobbit on a Solaris 10 zone -

Hi again,
      The various replies set me thinking again.

The non-global zone is indeed a whole root zone.  However, the users
directory filesystem /export is a loopback filesystem from the global
so that users in all the zones share a common home directory structure.
was building the hobbit kit in a subdirectory of /export/home/user1.  I
tried running the config/make sequence as both user1 and as root, both
failed as previously described.

As a result of the replies, I tried unpacking the kit in the root
filesystem, in /usr/local.  I ran the configure/make sequence as root (I
know, it's not best practice, but I was getting desperate) and it

I don't fully understand why - I thought hte root filesystem in a
non-global zone was effectively a loopback filesystem similar to my
filesystem, but that's the only difference I can see between this and my
previous efforts.

I now have a problem with the make install, but that looks like a simple
library path issue, so back to trawling the mail archives for me :-)

Thanks again for all the contributions,



To unsubscribe from the hobbit list, send an e-mail to
hobbit-unsubscribe at hswn.dk

More information about the Xymon mailing list