[hobbit] linux version

Charles Jones jonescr at cisco.com
Fri Jan 6 18:21:34 CET 2006


That looks good...if one of the libs was missing it would indicate it.  
My next guess would be webserver configuration issues (see my other 
email), and/or file permissions, like can the apache user access the 
files in your hobbit cgi-bin directory (test by su to the apache user 
and see if you can acesss the dir/files).


Michael Frey wrote:

> This is what I get when I run the ldd
> [root at nbtbigbro1 bin]# ldd hobbitgraph.cgi
>         librrd.so.2 => /usr/local/rrdtool-1.2.11/lib/librrd.so.2 
> (0x40018000)
>         libpng.so.2 => /usr/lib/libpng.so.2 (0x400ec000)
>         libc.so.6 => /lib/i686/libc.so.6 (0x4010d000)
>         libm.so.6 => /lib/i686/libm.so.6 (0x40248000)
>         libz.so.1 => /usr/lib/libz.so.1 (0x4026b000)
>         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
> Michael,
> Yes it looks like an issue with libpng. Verify this by going to your 
> hobbit directory, then cd to the "bin" directory, and run the ldd 
> command on hobbitgraph.cgi.  This will show all the libs that 
> hobbitgraph expects to find, and if it has access to them or not. 
>  Here is a sample output from my hobbit server:
> # ldd hobbitgraph.cgi
>        libpcre.so.0 => /lib/libpcre.so.0 (0x0098d000)
>        librrd.so.2 => /usr/local/rrdtool-1.2.11/lib/librrd.so.2 
> (0x00d35000)
>        libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00be1000)
>        libc.so.6 => /lib/tls/libc.so.6 (0x005cf000)
>        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00804000)
>        libz.so.1 => /usr/lib/libz.so.1 (0x00726000)
>        libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0x0044d000)
>        libm.so.6 => /lib/tls/libm.so.6 (0x006fb000)
>        /lib/ld-linux.so.2 (0x005b6000)
> I'm guessing that for you libpng is missing.  If you already have it, 
> but its in the wrong place, the fix can be as simple as making a 
> symlink to it, or copying it to where hobbit expects it to be.  Other 
> solutions include editing your /etc/ld.so.conf (run ldconfig 
> afterwards), or recompiling hobbit and giving it the exact location of 
> libpng.
> -Charles
> Michael Frey wrote:
> The specific issue I am having is with the history graphs drawing. 
>  Everything else is working fine.
> see screenshot:
> They used to work, but after a reboot, they failed.  I recall having 
> to manually copy ldpng somewhere, but that is it.
> I know I am in over my head with the linux piece, but it worked 
> before, and I am sure it is a simple fix; I just can't figure it out.
> I have some great resources here that know linux, but they are at a 
> loss with the pieces hobbit uses.
> Any suggestions for the cgi-graphing would simplify everything, as I 
> would eave the current build running.
> Michael Frey
> ------------------------------------------------------------------------
> *From:* Michael Frey [_mailto:michael_frey at glic.com_] *
> Sent:* Friday, January 06, 2006 11:00 AM*
> To:* _hobbit at hswn.dk_ <mailto:hobbit at hswn.dk>*
> Subject:* [hobbit] linux version
> I have had a linux rh 7.3 server running, and have had issues with the 
> history graphs.
> I tried to upgrade to Fedora C3, bit that looks to be missing some 
> important pieces.
> What would be the recommended version of Linux to avoid all of these 
> isuues?
> Redhat 9?
> Michael,
> What missing important pieces?  I have run hobbit on Redhat9, Fedora 
> Core 3, Fedora Core 4, Centos 3.x, Centos 4.x, and Solaris 10.
> All of the installs required fulfilling various dependencies like 
> rrdtool, libpng, etc. I would say the easiest install I did was on 
> FC4...I'm not sure you will find an OS that will have all of hobbits 
> dependencies available in the base packages branch, but with any 
> decently new distro you should have pretty much everything available 
> except rrdtool.  
> If you are the kind of person who prefers to use RPMs for everything, 
> check out Dags (_http://dag.wieers.com/home-made/apt/packages.php_), 
> they have RPMs for most distros (redhat 7,9,fc1-4,EL3-4) including 
> fping and rrdtool.  You can either download the rpms manually or add 
> dag to your yum.conf so you can just do "yum install rrdtool" and it 
> will automatically grab the dependencies too.
> Note I don't recommend this method for everyone...some people are 
> paranoid (rightfully so if security is a concern) and refuse to 
> install binary releases and only install manually from tarballs.
> -Charles
> ------------------------------------------------------------------------
> *This message, and any attachments to it, may contain information that
> is privileged, confidential, and exempt from disclosure under
> applicable law. If the reader of this message is not the intended
> recipient, you are notified that any use, dissemination, distribution,
> copying, or communication of this message is strictly prohibited. If
> you have received this message in error, please notify the sender
> immediately by return e-mail and delete the message and any
> attachments. Thank you. *

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xymon.com/pipermail/xymon/attachments/20060106/1b999899/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 2604 bytes
Desc: not available
URL: <http://lists.xymon.com/pipermail/xymon/attachments/20060106/1b999899/attachment.gif>

More information about the Xymon mailing list