[hobbit] linux version

Michael Frey michael_frey at glic.com
Fri Jan 6 17:55:50 CET 2006

The specific issue I am having is with the history graphs drawing. 
Everything else is working fine.
see screenshot:

They used to work, but after a reboot, they failed.  I recall having to 
manually copy ldpng somewhere, but that is it.

I know I am in over my head with the linux piece, but it worked before, 
and I am sure it is a simple fix; I just can't figure it out.

I have some great resources here that know linux, but they are at a loss 
with the pieces hobbit uses.

Any suggestions for the cgi-graphing would simplify everything, as I would 
eave the current build running.

Michael Frey

Charles Jones <jonescr at cisco.com> 
01/06/2006 11:29 AM
Please respond to
hobbit at hswn.dk

hobbit at hswn.dk

Re: [hobbit] linux version

From: Michael Frey [mailto:michael_frey at glic.com] 
Sent: Friday, January 06, 2006 11:00 AM
To: hobbit at hswn.dk
Subject: [hobbit] linux version
I have had a linux rh 7.3 server running, and have had issues with the 
history graphs. 
I tried to upgrade to Fedora C3, bit that looks to be missing some 
important pieces. 
What would be the recommended version of Linux to avoid all of these 

Redhat 9? 

What missing important pieces?  I have run hobbit on Redhat9, Fedora Core 
3, Fedora Core 4, Centos 3.x, Centos 4.x, and Solaris 10.

All of the installs required fulfilling various dependencies like rrdtool, 
libpng, etc. I would say the easiest install I did was on FC4...I'm not 
sure you will find an OS that will have all of hobbits dependencies 
available in the base packages branch, but with any decently new distro 
you should have pretty much everything available except rrdtool. 

If you are the kind of person who prefers to use RPMs for everything, 
check out Dags (http://dag.wieers.com/home-made/apt/packages.php), they 
have RPMs for most distros (redhat 7,9,fc1-4,EL3-4) including fping and 
rrdtool.  You can either download the rpms manually or add dag to your 
yum.conf so you can just do "yum install rrdtool" and it will 
automatically grab the dependencies too.

Note I don't recommend this method for everyone...some people are paranoid 
(rightfully so if security is a concern) and refuse to install binary 
releases and only install manually from tarballs.


This message, and any attachments to it, may contain information that
is privileged, confidential, and exempt from disclosure under
applicable law.  If the reader of this message is not the intended
recipient, you are notified that any use, dissemination, distribution,
copying, or communication of this message is strictly prohibited.  If
you have received this message in error, please notify the sender
immediately by return e-mail and delete the message and any
attachments.  Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xymon.com/pipermail/xymon/attachments/20060106/023e9bd1/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 2604 bytes
Desc: not available
URL: <http://lists.xymon.com/pipermail/xymon/attachments/20060106/023e9bd1/attachment.gif>

More information about the Xymon mailing list