[hobbit] Hobbit client OS support issues

Henrik Stoerner henrik at hswn.dk
Tue Aug 9 19:36:22 CEST 2005

On Tue, Aug 09, 2005 at 10:26:16AM -0400, Michael Nemeth wrote:
> OK with the latest  snapshot  09-Aug-2005  Im able to compile on:
> Solaris 2.6 with no issues,
> hp11 with no issues  except changing CC=cc to CC=gcc


> hp1020  issue:  the -lnsl  flag  , library not found.  I tried -lresolv 
> no luck .  I removed both and it compiled; is this OK does the client
> use this?

If it compiles OK, then it isn't needed. All library dependencies are
resolved at compile/link time.

> At this time I cannot test if they  actually work except for hpux 11.
> With hpux 11 client two issues:
> the network I/O graph stopped working  . Stop working after a snapshot 
> from last week.  Looks like it worked with 4.1.1.
> I tried stopping hobbit and removing  the rrd  with no luck.

Please send me a copy of the client/tmp/msg.txt from this client. I did
some work on the netstat parser, so it is quite possible that I broke
something - having a sample of the input data makes testing a lot

> Next is not a big issue yet (it may/should  be on my Classed side where 
> clearcase runs)
> Disk is picking automounts:
> /sw1/usr/local 4183116 4010394 172722 96% 
> /usr/local                        this is an automount

OK, I need your expertise here: As you can see in the
hobbiclient-hpux.sh script, it runs the command "df -Pk" to get the df
data. What options can be added to the df command line to avoid picking
up these mounts ?


More information about the Xymon mailing list