[Xymon] http test flapping

Galen Johnson solitaryr at gmail.com
Fri May 11 03:21:13 CEST 2018


I'm hoping someone has run into this and was able to track down how to
determine why http tests are flapping.  They used to run consistently for
days but now I'm lucky if the test stays green for more than a minute.
It's rarely the same test twice that fails (times out?) and sometimes it's
different hosts.  The history looks like a christmas-y candy cane.
However, if I run curl commands, they work fine.  I'm strongly suspicious
it's a network or system resource issue but I can't even see anything that
is actually logging why it's failing.  I've tried bumping the timeout up
but that doesn't seem to help.  Anyone have any ideas on what I can bump to
either get better logs or where else to look?  Only http is experiencing



NB: this is running the Terabithia 4.3.28 RPMs on Centos 7.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xymon.com/pipermail/xymon/attachments/20180510/1da1dd97/attachment.html>

More information about the Xymon mailing list